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About this Practice Workbook...
 This PDF file includes bookmarks providing an overview of the document. Click on the bookmark to quickly jump to 

any section in the file.

 Both Imperial and Metric files are included in the dataset. Throughout this practice workbook Imperial values are 
specified first and the metric values second with the metric values enclosed in square brackets. For example: 12’ 
[3.4m] 

 This course workbook uses the Training and Examples workspace delivered with the software.

 The terms Left-click, Click, Select and Data are used interchangeably to represent pressing the left mouse button. 
The terms Right-click and Reset are also used interchangeably to represent pressing the right mouse button. If your 
mouse buttons are assigned differently, such as for left-handed use, you will need to adjust accordingly.

Have a Question? Need Help?
If you have questions while taking this course, search in CONNECT Advisor for related courses and topics. You can 
also submit questions to the Civil Design Forum on Bentley Communities where peers and Bentley subject matter 
experts are available to help.

Course Level: Fundamental

http://learn.bentley.com
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Course Overview

This workbook is designed to help users understand the basic tools within OpenSite Designer. Users will learn workflows for creating a site 
project and also learn about using the new automation and optimization tools for grading.

The complete site design is shown below. We will begin with the conceptual horizontal layout of the site by creating the building footprint, 
parking lots, main drive and connector drives.

Once the conceptual horizontal layout is complete we will run the Grading Solver which will optimize the grading for the site and also define 
the elevations of the 3D site elements.
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Exercise 1: Getting Started

In this exercise, you will learn to start the software, select the proper WorkSpace & WorkSet, open a design file, review the interface, attach 
reference files, set the active terrain model and define 2D & 3D Model Views.

Skills Taught
 Start the Software

 Select WorkSpace and WorkSet

 Open a 2D Design File (.dgn)

 Review the Ribbon Interface

 Review CONNECT Advisor 

 Attach Existing Terrain and GIS Parcels Reference Files

 Set Active Terrain Model

 2D and 3D Model Views
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Start the Software and Open a Design File

In this section you will start the software, set the workspace & workset and then open a design file.

1. Start the software.

2. Set the WorkSpace and WorkSet

The workspace and workset define standards that are used by the software. The WorkSpace and WorkSet used for this training are 
installed during the software installation.

a. Select Training and Examples from the WorkSpace drop-down menu.

b. Select Training-Imperial [Training-Metric] from the WorkSet drop-down menu.

3. Open an existing file.

a. Select Open File.

b. Browse to C:\Bentley Training\Introduction to OpenSite Designer or other folder where you unzipped the dataset files.

c. Open the file named Site-Model.dgn [Metric-Site-Model.dgn].
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Navigating the Interface

Tools can be accessed a variety of ways, including the familiar Ribbon interface. Ribbons are arranged by Workflows, which are selected from 
a pull-down in the upper left corner of the software.

1. Activate the OpenSite Modeling workflow from the pick list in the upper left corner if it is not already active. 
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The ribbon menu will reflect the OpenSite Modeling tools. The tools are organized into categories on the ribbon tabs.

 Home - Common tools such as Attributes, Explorer, Attach Reference Tools, Models, Level Display and Element Selection.

 Note the OpenSite Help tool in the upper right corner of the ribbon. (Home > OpenSite Help > OpenSite Help)

 Terrain - Element selection and terrain modeling tools.

 Geometry - Element selection, Civil AccuDraw and geometry tools including Lines, Arcs, and Points.

 Site Layout - Element selection and specialized groups of tools for site layout and design (Draw Basic, File Import, Parking, Pad, 
Pathway, Vertical Geometry, Grading Proposed and Modify Phase).

 Template Modeling - Element selection, superelevation and corridor modeling tools.

 Model Detailing - Element selection, Civil Cells and 3D tools (Linear Templates, Surface Templates, etc.)

 Drawing Production - Element selection, saved views, notes, text, annotations, and plans production (cross section, plan, and profile) 
tools.

 Drawing - Commonly used MicroStation drawing tools. To the complete set of MicroStation tools change the active workflow to 
Drawing, Modeling (3D only) or Visualization (3D only).

 View - Commonly used view control tools.

2. Click on each of the Ribbon tabs and notice how each tab has a different set of tools.

The Quick Access Toolbar to the right of the Workflow drop down list contains 
common tools like Create New File, Open File, Save Settings Compress File, 
Undo, Redo, Print, Explorer and Properties. It is easily customizable.
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A Search Ribbon tool is also available at the right side of the title bar. Use it to find tools 
across the multiple ribbons. When you are not sure where to find a tool, simply type the 
command in the Search Ribbon field and a search will be performed across all ribbon 
menus.

Shown to the right are results for a search for Geometry.

3. Search for a tool using the search ribbon. Key in Parking in the Search Ribbon field.

4. Notice the results of the ribbon search are displayed in a dialog below the Search 
Ribbon field.

5. Click on Show Details in the bottom right corner of the dialog, the tool list will be 
expanded and the description of the tools are now shown.
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6. Hover over Parking Lot

The search results expand, showing where the Parking Lot tool is located in the 
ribbons: OpenSite Modeling -> Site Layout -> Parking. You may have different or 
additional paths.

Clicking on the OpenSite Modeling -> Site Layout -> Parking path will open the tool.

7. In the Search Results dialog, Left-click Parking Lot to open the Place Parking tool.

8. Right-click to close the toolbox.
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9. Introduction to the Back Stage View.

a. Activate the Back Stage View by clicking File in the ribbon menu.

The Back Stage View will appear.

Notice the various options on this screen such New, Open, Save, Save Settings, Settings, Help, etc. Some of these “File” tools are 
available from the Quick Access Toolbar, but the bulk of the File capabilities are here. 
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b. Select Settings.

Settings are broken up logically. User, System, File and Configuration all have corresponding tools here. This keeps the ribbon menus 
focused on the engineering and production tools.

c. Click the Arrow in the upper left corner to return to the main ribbon interface.
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Help and CONNECT Advisor

In this section you will explore two primary Help Sources. 

The upper right corner of the OpenSite window has a button for Help  and CONNECT Advisor 

1. Click the Help button.

The help file is located online make sure you have internet connectivity. You also have the option to view offline help as well.

a. Click OK to launch the online help. The Help button launches the familiar interface of Indexed, Searchable and Hyperlinked topics.
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CONNECT Advisor is a software component/desktop application which provides a unified interface for you to interact with various Bentley 
content in one location, thereby eliminating the need to browse to various sources individually. CONNECT Advisor boosts productivity as it 
reduces the time required to access and get information. You get the ability to browse-search-view-interact without having to leave the 
application that you are working on. 

CONNECT Advisor performs the following functions: 

1. It provides you with information related to a. Posts, Wikis, and Blogs from 
Bentley Communities 

 Videos, Hands-on, and Assessments from Bentley LEARN server 

 Videos from Bentley YouTube Channels 

 Bentley News and Announcements 

 Upcoming Bentley Events 

 Product Help 

2. It provides you with a unified interface that displays the above items all 
gathered from their respective sites and locations. 

3. It gives you the ability to search within all the available sources (Bentley 
Communities, Bentley Learn, Bentley YouTube channels, Bentley News and 
Announcements, Bentley Events, Product Help.) 

4. It enables you to filter information based on:

 Product Generation 

 Release Label 

 Language 

 Content Type 

 Tags, Region, etc. 
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New functionality and improvements are being added regularly. The surest way to have up-to-date training for CONNECT Advisor is to click on 
its Help button. From its Help you can get version-appropriate help. It provides all the CONNECT Advisor training you need.
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Attach Reference Files

In this section, you will learn to attach the existing terrain model (i.e. existing topography) and GIS parcel data. We will use these files 
to help layout the site.

1. Activate the OpenSite Modeling workflow from the pick list in the upper left corner of the screen.

2. Attach the existing terrain model file.

a. From the ribbon menu select Home > Primary > Attach Tools > References

b. Select Attach Reference 

c. Select the file Terrain_Existing.dgn [Metric-Terrain_Existing.dgn]

d. Set Attachment method to Coincident World.

e. Select Open to attach the file.

The Terrain_Existing.dgn will now appear in the References dialog. 
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3. Review the existing terrain.

a. Click in View 1 to make it active and select Fit View.
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4. Using the References tool, attach the GIS_Parcels.dgn file.

a. Select Attach Reference 

b. Select the file GIS_Parcels.dgn 

c. Set Attachment method to Coincident World.

d. Select Open to attach the file.

The GIS_Parcels.dgn is now attached.

e. Close the References dialog.
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Before we continue, lets be sure that the terrain model and GIS parcel files that were attached are in the correct location geographically. 
A good way to check this is to turn on the Background Map in the view (Internet connection is required for this to work).

5. Turn On the Background Map Aerial Imagery.

a. Select View Attributes.

b. Expand the Background Map panel by clicking the down arrow.

c. Set the Background Map Type to Aerial.

The aerial image will be automatically shown. The terrain model and GIS parcels are in the proper location as we expected. The aerial 
image is being pulled from Bing Maps and is utilizing the geographic coordinate system that is assigned to this design file.
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The next thing we need to do is set the terrain model active so the software knows that the existing terrain stored in the 
Terrain_Existing.dgn will serve as the foundation of our site design.

6. Set the Terrain Model Active.

a. Select the Element Selection tool from Home > Selection > Element Selection

b. Set the Element Selection tool to individual mode by selecting the individual and new icons.

Notice in View 1 the green shape, this shape represents the terrain model boundary.

c. Click anywhere on the terrain model green shape. Hover your cursor at this location for a few seconds until the context sensitive menu 
appears.

d. Select Set As Active Terrain Model.

Note: Setting the Terrain Model active will automatically create a 3D Model if one does not already exist in the active design file.
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Next we will take a quick look at reviewing the 3D model and setting up 2D and 3D views.

7. Set up and review the 2D and 3D Views. 

a. Press F9 (or use View Control as described in step b. below).

 Notice the view windows will now have a 2D View and a 3D View. Even though this is a 2D dgn file, you have the ability to have 2D 
Models and 3D Models in the active dgn file. 

 View 1 is the Default 2D model and View 2 is the Default-3D model (created automatically when you set the terrain model active). 

 This view setup is typically desirable. Any time there is 3D information associated with elements, it will be displayed in the Default-
3D model.

TIP: Always pay attention to which model is the active model.

b. Alternatively, you can Right-click in View 1 and hold down the right mouse button to access special view control tools. 

c. Select View Control > 2 Views Plan/3D

8. Close View 2, since we will not be working with anything in the 3D model just yet. 

We will deal with creating 3D elements later in the course.
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Exercise 2: Design Site Layout

In this exercise, you will learn how to create a site plan consisting of parking lots, building footprint, main drive and connecting drives. The 
exercise will also cover how to make some object revisions.

Skills Taught
 Create Building Footprint

 Create and Edit Main Drive

 Create and Edit Parking Lots

 Review Site Layout Settings

 Review Site Feature Properties with Explorer

 Create and Edit Parking Lot Drive Connectors
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Create Building Footprint

Depending on the type of project a desired building footprint may be known. For this project were are going to reference a footprint provided 
by Architect that was designed in OpenBuildings. The building footprint is geolocated and will be located at the Architect’s desired location.

1. Using the References tool, attach the Bldg_Footprint.dgn file.

a. From the ribbon menu select Home > Primary > Attach Tools > References

b. Select Attach Reference.

c. Select the file Bldg_Footprint.dgn.

d. Set Attachment method to Coincident World.

e. Select Open to attach the file.
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2. Now that the building footprint has been attached we need to define the building footprint with OpenSite Modeling tools.

a. Select Site Layout > Pad > Building

b. Set the Feature Definition to Building Footprint > Site_Building

c. Set the Name Prefix to BLDG

d. Follow the heads-up prompts:

 Method: Pick Points

 Enter First PI: Pick the southwest corner of the building to place the first PI 
point.

 Enter Next PI/Back Radius: Pick the northwest corner of the building to place 
the second PI point.

 Enter Next PI/Back Radius: Pick the northeast corner of the building to place 
the third PI point.

 Enter Next PI/Back Radius: Pick the southeast corner of the building to place 
the third PI point.

e. Right click to complete.

f. Right click again to exit the command.

3. Now that the building footprint has been defined we can turn off the building footprint 
reference file.

a. Select Home > Primary > Attach Tools, the References dialog will appear.

b. Select the Bldg_Footprint.dgn

c. Select the Display tool to turn off the reference file.

d. Close the References dialog.
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Create Main Drive

For this project there will be a main drive that runs through the project starting at the intersection to the north and terminating into the roadway 
on west side of project. In this section, you will learn how to create the main drive.

1. Layout the driveway using the image below as guide.

a. Select Site Layout > Pathway > Driveway

b. Set the Feature Definition to Driveway > Site_Driveway_Light_Duty_Full_Depth_Asphalt

c. Set the Name Prefix to DRIVE

d. Follow the heads-up prompts:

 Method: Pick Points

 Enter First PI: Pick starting point being edge of pavement at the intersection on the north boundary of project. 

 Enter Next PI/Back Radius: Move your cursor southwest approximately 200’ [60] to place the second PI point.

 Enter Next PI/Back Radius: Move your cursor southwest and parallel with the property line approximately 200’ [60] to place the 
third PI point.

 Enter Next PI/Back Radius: Move your cursor northwest and parallel to the south building face and pick the edge of pavement as 
the last PI point.

e. Right click to complete.
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f. Right click again to exit the command.

2. Now that the drive has been placed, change the radius for each curve to 50’ [15].

a. Select the drive, the dynamic text manipulators will now be displayed and available for in-place editing. 

Also, note the drive width values and graphically manipulators along the driveway centerline. The graphical manipulators allow you to 
move the driveway as needed.

b. Hover your cursor over the curve PI manipulator until the radius manipulators appear.

c. Click on the radius value manipulators (they will be displayed as 0) and change them to 50’ [15].

The centerline geometry will update and the edges of the driveway will now follow the updated geometry.
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Create Parking Lots

For this project there will be two parking lots with two drive connectors. This exercise will go through how to create parking lots and how to 
place and revise drives.

1. Layout the parking lot using the image as a guide.

a. Select Site Layout > Parking > Parking Lot

b. Set the Feature Definition to Parking Lot > 
Site_Parking_Light_Duty_Full_Depth_Asphalt

c. Set the Name Prefix to PRK_LOT

d. Follow the heads-up prompts:

 Method: Pick Points

 Enter First PI: Pick the southeast corner of the 
building.

 Enter Next PI/Back Radius: Move your cursor parallel 
along the back face of the building and pick a point 
where the property line and sidewalk intersect.

 Enter Next PI/Back Radius: Move your cursor 
southeast along the property line a distance of 
approximately 180’ [55].

 Enter Next PI/Back Radius: Follow the main drive to south until first turn and pick next point. 
 Enter Next PI/Back Radius: Follow the main drive to the southwest and set point in line with south side of building

e. Right click to complete.

f. Right click again to exit the command. 

The parking lot design will be automatically created based on design standards that are defined in the Site Layout Settings. These 
settings can be changed at anytime during the design process.
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2. Now that the main parking lot area is complete we will now place a front parking lot area. Use the image below as a guide.

g. Select Site Layout > Parking > Parking Lot

h. Set the Feature Definition to Driveway > Site_Parking_Light_Duty_Full_Depth_Asphalt

i. Set the Name Prefix to PRK_LOT_FRONT

j. Follow the heads-up prompts:

 Method: Pick Points

 Enter First PI: Pick the southwest corner of the building.

 Enter Next PI/Back Radius: Following along the west face of the building pick the northwest corner of the building.

 Enter Next PI/Back Radius: Set the next point approximately 60.1’ [18] from the previous point.

 Enter Next PI/Back Radius: Next create the western side of parking by drawing the next segment 159’ [48] long at a right angle 
from previous segment.

 Enter Next PI/Back Radius: Pick on starting point.

k. Right click to complete and then Right click again to exit the command.
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3. The short end of front parking area needs to revised to remove parking 
spaces. 

a. Zoom in to the northeastern edge of the front parking lot

b. Select the 3 space parking area. Once selected the dynamic text will 
appear.

c. Hover your cursor over one of the parking space elements, the 
Properties tool will appear.

d. Select Properties.

e. In the Properties panel, change Has Parking from True to False. This will remove parking stalls along north edge of parking.

The Properties tool can be used to make changes to any site feature at any time. Notice the various fields available for editing (Has 
Aisle, Aisle Width, Has Curb, Curb Height, etc.) simply click in the property field that you would like to adjust and the site feature will 
update automatically.
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f. Repeat the process to remove the 3 parking spaces along the southern edge of the parking lot.

When we first placed the parking lot you may have noticed we didn’t enter any design or layout information. We simply drew some shapes and 
all of the parking spaces, islands and aisles where created automatically in a logical manner. This is by design. OpenSite has predefined 
design standards and layout properties that are configured in the Site Layout Settings. 
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Review Site Layout Settings in Explorer

The default design standards and layout settings for the parking lot are defined in the Site Layout Settings which can be found in the OpenSite 
Standards panel in the Explorer. The Site Layout Settings contains all of the default rules for how site objects and features get built.

1. Open Explorer and review the Site Layout Settings for the 
parking lot.

a. Select Explorer.

b. Navigate to OpenSite Standards pane and expand the 
pane by clicking on the down arrow.

c. Expand the Standards category by clicking the arrow on 
the left.

d. Select Site-Model.dgn (Default) and expand the list until 
you can see the Site Layout Settings.

e. Expand Site Layout Settings until you see all of the site 
settings as listed in the image to the right. 

This area is where all of the design standards and layout 
settings are defined for the various site objects.

2. Review the design standards and layout settings for the 
Parking Lot Area.

a. Select Area category listed under Parking Lot Default 
Properties.

b. Right click and select Properties to review the design 
standards and layout settings for the parking area.

c. Close the Properties pane.
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Review Site Objects in Explorer

As you build site objects and features they are managed and organized in the OpenSite Model within the Explorer tool. The OpenSite 
Model gives you detailed information and access to each site object and its associated features.

1. Review Site Objects.

a. Navigate to the Explorer tool on the left side of the screen.

If the Explorer is not open, select Home > Explorer.

b. Click on the down arrow to the right of the OpenSite Model panel to expand the panel.

You will now be able to see all of the OpenSite object categories near the bottom of the list.

c. Click the arrow next to each site object category to further expand the list until you see all of 
the site objects that make up our site.

d. Select the site object named BLDG, this is the building object. Notice that when you select 
the object it highlights in View 1. 

Most site projects have several site objects and these objects sometimes can be hard to 
find in the design file. Simply selecting objects from the list makes it easy to locate in the file 
for when you need to make changes.

e. Right click on BLDG and select Zoom to. The BLDG object will highlight and the view will 
zoom in and center on the building object.

The right click functionality can also be used to dig deeper into a site elements design 
parameters to make changes via the Properties tool.

f. Right Click on BLDG and select Properties. Note the design properties: Phase, Grading, 
Feature, Building, Type, etc. Any of these design properties can be changed at any time 
and the layout will automatically update.

g. Close the Properties pane.
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Drive Connector from Parking Lot to Main Drive

With Main Drive and Parking Lots created a connection point between the two need to created. The driveway tool will be used to make this 
connection.

1. Select Site Layout > Pathway > Driveway

a. Set the Feature Definition to Driveway > 
Site_Driveway_Light_Duty_Full_Depth_Asphalt

b. Set the Name Prefix to DriveConn1 

c. Follow the heads-up prompts:

 Method: Pick Points

 Enter First PI: Using the mid-point snap, pick the mid-point along the 
southern edge of the front parking lot.

 Enter Next PI/Back Radius: Using the nearest snap, pick a point on 
the main drive along the north edge of the drive.

d. Right click to complete.

e. Right click again to exit the command.

Note: The drive will be created using design settings found in the Site Layout Settings. The Site Layout Settings contains all of the 
default rules for how site objects and features get built.
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2. Repeat the same process to create a drive that connects the rear parking lot at the mid-point to the main drive. 

a. Set the Feature Definition to Driveway > Site_Driveway_Light_Duty_Full_Depth_Asphalt

b. Set the Name Prefix to DriveConn2 

c. Follow the heads-up prompts:

 Method: Pick Points

 Enter First PI: Using the mid-point snap, pick the mid-point along the eastern edge of the rear parking lot.

 Enter Next PI/Back Radius: Using nearest point snap, pick a point on main drive along the north edge of the drive.

d. Right click to complete.

e. Right click again to exit the command.

Note: If your drive does not display it is because there is not enough room between the main drive and the parking lot. You will have to 
move the parking lot edge to the west a few feet in order to construct the drive.

3. If the drive did not display, follow the steps on the next page to adjust the parking lot.
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4. Review the Parking Lot and move the eastern edge of the parking lot a little farther west away from the main drive.

a. Using the element selection tool, select the Parking Lot.

b. Hover your cursor over the diamond shaped manipulator near the mid-point along the eastern edge of the parking lot. This allows you 
to adjust either the inside or outside of the parking lot.

c. Select the arrow that points toward the inside of the parking lot and move it a few feet west to create more space between the parking 
lot and main drive. Use the image above as a guide.

 The entire parking lot will update and the new connector driveway will appear now.

 If the new connector driveway does not appear, you may need to place another drive between the parking and main drive.
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5. Change the radius returns at the main drive.

a. Select the end of the drive located at edge of main driveway. A magenta X 
will highlight the point at the end of connection line. 

b. Select this X manipulator.

c. Hover the cursor over the X and select Properties.

d. The Properties panel will show design controls for the drive point.

e. Change the Entrance Flares Radius to 2.

f. Change the Exit Flare Radius to 2. The radius returns will update.

6. Change the radius returns at the parking lot.

a. Select the end of the driveway located at the edge of the parking lot. A 
magenta X will highlight the point at the end of connection line. 

b. Select this X manipulator.

c. Hover the cursor over the X and select Properties.

d. The Properties panel will show design controls for the drive point.

e. Change the Entrance Flares Radius to 2.

f. Change the Exit Flare Radius to 2. The radius returns will update. 

The length of the driveway will also adjust. You may need to extend the 
driveway using the manipulators if the radius returns undisplay.
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Exercise 3: Project Grading

In this exercise you will learn about optimized grading performed by the Grading Solver.

Skills Taught
 Grading Solver

 Optimize Project Grading

 How to Modify the Phase

 3D Model and Cross Section Review

 Linear Templates
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Project Grading

With the conceptual site plan complete the next step is to create the grading for the project. Grading will allow a better understanding of 
feasibility of the conceptual layout.

1. Open 3D Model View and create the project grading.

a. Press F9 on your keyboard, this will open 3D Model in View 2. Currently, the only 3D data that exists in the 3D model is the existing 
terrain. 

We are now going to run the Grading Solver which will analyze the conceptual horizontal layout against the existing terrain and 
determine the optimized grading and also create vertical geometry and 3D features of the conceptual design.

b. Select Site Layout > Grading Proposed > Grading Solver

Once selected a second window will open to show the site going through grading optimization.
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Once the grading optimization is complete the results will be displayed in the Landscape 3D Viewer and 3D features will be created in 
the 3D Model. 

Use the Landscape 3D Viewer to analyze the results of the grading optimization. Notice it displays the earthwork quantities in the lower 
right portion of the screen.

2. Review the results in the Landscape 3D Viewer window. 

a. Select the Boundary toggle at the bottom of the viewer to change the display to a color coded representation of the design.

The toggles at the bottom of grading 
viewer will control what information is 
shown.

 Type of Surface show (i.e. 
Graded, original, graded & 
original, etc.)

 Surface Triangles

 Surface

 Boundaries (colored 
representation of design)

 Contours

 Scale

 Lower right hand corner shows 
amount of earthwork being done.
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3. Review the Contours and 3D Model.

Notice the 3D Model does not show a lot detail. This is because all of the site elements were placed using the default Phase of 
Concept (only terrain models will be created for each site object). To see a more a detailed 3D model you need to change the Phase 
for each site object from Concept to Preliminary (terrain models with surface templates will be created) or Final (terrain models with 
surface templates and linear templates will be created). 

OpenSite elements can placed as: Concept, Preliminary or Final. 

 Concept and Preliminary are tied directly to the grading solver. As you make changes the grading solver will still optimize the site.

 Final is used to fine tune the design and allows the user to make user defined changes that does not affect the results of the 
grading solver. 

4. Change the Phase to Final.

a. In View 1, using the element selection tool, select all of the site elements (You should have a total of six elements).

b. Select Modify > Modify Phase

c. Select Final.

When you select Final, terrain models and surface templates are applied to the site elements and you now get a more detailed 3D 
model.
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5. Review the 3D Model. Now you will see more detail. You will see that the building footprint will have a concrete material thickness and the 
driveway and parking lot will have asphalt material thickness. The materials can be easy quantified since they are 3D elements.

To get a better look at the material thicknesses and grading. Let’s take a look at a cross section through the site.

6. To view a cross section you must first place a reference line or alignment across the site.

a. Select Geometry > Horizontal > Lines > Line Between 
Points

b. Set the Feature Definition to Alignment > 
Geom_Baseline

c. Set the Feature Name to Ref Line

d. Follow the prompts and use the image below as a guide 
to the place the reference line:

 Enter Start: Select a point near the mid-point of the 
existing western roadway.

 Enter End: Select a point to the west of the main 
drive.
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7. Create the Cross Section

a. Select Template Modeling > Dynamic Sections

b. Follow the heads-up prompts:

 Locate Corridor or Alignment: Select the reference line.

 Left Offset: -200 [60], press Enter to lock the value.

 Right Offset: 200 [60], press Enter to lock the value.

 Station: 0+90 [0+030], press Enter to lock the value.

 Interval: 50 [10], press Enter to lock the value

 Select or Open View: Select View 8 from the view control buttons at the bottom of the screen.

 Data point or Left Click in View 8.

The cross section will now be displayed in View 8.

What you see in the cross section window is a “slice” through the 3D model. Any 3D element displayed in the 3D model will be 
shown in the cross section. Also, note the curb, parking lot and main drive all have material thickness. This material thickness 
comes from surface templates that are applied to the terrain models for each of these site elements.
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c. Use the navigation buttons to scroll through the cross sections.

Notice that we don’t have any grading that ties to existing ground on the right side of the main drive. We will address this by adding a 
Linear Template along the south edge of the main drive.

8. Apply a Linear Template along the south edge of the main drive.

a. Select Template Modeling > Apply Linear Template

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Element to Apply Template: In the 2D view or 3D View, select 
the CURB_BACK_TOP feature (i.e. top back of curb).

In the 2D View, you may need to turn off the Constructions in the View 
Attributes to better see the CURB_BACK_TOP feature.

 Feature Definition: Linear Template > Final

 Name: Grading

 Template: Press <ALT> and the Down Arrow to open the template 
library. The Pick Template window will appear.

 Browse to the Site Layout > Linear Templates > End Conditions folder 
and select Simple Tie Slope and click OK

 Start Station: Press <ALT> to lock to start

 End Station: Press <ALT> to lock to end

 Select Side - Reflect Option: Move the cursor away from the main drive 
southern edge so the grading is created on the outside.

 Exterior Corner Sweep Angle: Do not change the setting. 

 Description: Grading

Tip: If the grading displays on the wrong side, the Properties dialog can be used to flip the Reflect option.
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9. Review the 3D Model and Cross Sections.

NOTE: The Linear Templates can be used to complete the grading for the rest of the project by simply applying them to the other 
CURB_BACK_TOP features.


	Course Overview
	Exercise 1: Getting Started
	Start the Software and Open a Design File
	Navigating the Interface
	Help and CONNECT Advisor
	Attach Reference Files

	Exercise 2: Design Site Layout
	Create Building Footprint
	Create Main Drive
	Create Parking Lots
	Review Site Layout Settings in Explorer
	Review Site Objects in Explorer
	Drive Connector from Parking Lot to Main Drive

	Exercise 3: Project Grading
	Project Grading


